Friday, August 4, 2017

Membuat Inquiries Sederhana Microsoft Dynamic AX 2012 (AXAPTA)

Pada Tutorial ini saya akan membahas dasar untuk membuat sebuah inquiries sederhana pada Microsoft Dynamic AX yang ditujukan untuk memudahkan user dalam mengakses data. Tentunya apabila inquiries sudah kita optimalkan dan juga filternya sudah berjalan semua namun pada tutorial kali ini akan saya mulai dengan hanya membuat inquiries paling sederhana yaitu menampilkan isi dari sebuah tabel, contohnya tabel PurchTable.
  1. Buka Ms Dynamic AX dan masuk mode Development dengan menekan tombol CTRL + D.
  2. Buat Project baru dengan cara buka menu Project, kemudian pada folder shared klik kanan New dan isikan nama Project, kali ini saya menggunakan nama SAN_LatihanLukman.
  3. Setelah Project terbuat, buat form dengan cara klik kanan pada nama Project pilih New kemudian Form, maka akan seperti gambar di bawah ini :
  4. Secara default setelah form terbentuk akan ada Methods, Data Sources, Parts, Designs, Permisssions. Untuk langkah awal klik kanan pada Data Sources kemudian pilih New Data Source dan seperti biasanya berikan nama untuk Data Source Baru atau pada contoh ini saya biarkan dengan nama default DataSource 1.
  5. Klik kiri pada DataSource 1 dan lihat pada windows sebelah kanan, kemudian pada Table pilih PurchTable (pilih tabel yang akan digunakan sebagai source).
  6. Setalah DataSource siap, kita akan mulai mengatur tampilan darin inquiries yaitu pada bagian Designs pada Form. Klik tombol + pada Designs.
  7. Akan ada 2 item pada Designs yaitu Design dan Design List, gunakan design untuk memulai membuat interface sedangkan design list akan memunculkan detail item apa saja yang kita gunakan pada interface.
  8. Klik kanan pada Designs kemudian New Control pilih Grid (disini grid kita gunakan untuk menampilkan data).
  9. Untuk memaksimalkan Grid agar bisa full screen klik pada Grid, pada windows kanan bagian Width ubah dari auto menjadi Column width, Height ubah dari auto menjadi Column Height dan pada Allow Edit ubah dari Yes menjadi No (agar inquiries datanya tidak dapat diubah user karena tujuannya hanya ditampilkan).
  10. Setelah grid terbentuk kita akan memastikan field mana saja akan kita tampilkan pada grid dari tabel PurchTable, buat satu persatu field dengan cara klik kanan New Control dan pilih sesuai dengan tipe data dari field tersebut, misal PurchName menggunakan StringEdit, AccountingDate menggunakan DateEdit.
  11. Pada contoh simple kali ini kita akam membuat field PurchID, PurchName, AccountingDate dan InvoiceAccount (apabila ingin lebih silahkan anda tambahkan sendiri). Setelah dibuat masing-masing tipe data perlu dicocokan dengan data pada tabel dengan cara klik salah satu control baru dari grid misal PurchID kemudian pada windows sebelah kanan cari bagian DataSource ubah dari kosong menjadi sesuai datasource kalian misal DataSource 1, DataField ubah dari kosong menjadi sesuai dengan field yang diinginkan misal PurchID.
  12. Lakukan hal yang sama pada setiap control baru yang dibuat dari data Grid.
  13. Setelah itu coba buka form untuk memastikan apa sudah berjalan untuk inquiries ini, dengan cara klik kiri pada form kemudian pilih Open
  14. Apabila sudah sesuai harusnya akan muncul tampilan seperti di bawah
Sekian tutorial dasar pembuatan Inquiries pada Microsoft Dynamic AX 2012 (AXAPTA), untuk filter data dan menggunakan lebih dari 1 datasource akan saya bahas pada artikel selanjutnya.

Menjalankan Program Dengan User Lain

Terkadang ada kalanya kita butuh untuk menjalankan suatu program dengan menggunakan user lain, apalagi kalau kita bekerja pada bagian IT suatu perusahaan yang akan mencoba untuk melakukan test settingan baru pada user tertentu maka cara ini akan sangat membantu ketimbang harus mencoba langsung pada PC / Laptop user.

Pada contoh kali ini saya akan mencoba running Microsoft Dynamic AX dengan menggunakan user lain selain administrator, caranya cukup mudah yaitu buka cmd atau commandpromt kemudian ketikkan perintah seperti berikut tanpa kurung :

(runas /user:domain\nama_user "ax32 c:\SAN_LIVE.axc")

Setelah itu akan ditanyakan password untuk user tersebut, masukkan dan enter. Dengan perintah di atas cukup akan membuat running program kalian dengan user yang diinginkan.

Thursday, July 6, 2017

PORT FORWARDING MIKROTIK

Bagi temen-temen yang sudah sering bergelut di bidang IT lebih spesifik ke jaringan komputer maka Port Forwarding sudah menjadi hal yang biasa, tujuannya adalah agar kita dapat mengakses perangkat yang berada di dalam network dari luar network atau internet padahal IP Public hanya ada satu atau terbatas.

Port forwarding sering digunakan untuk CCTV agar dapat diakses dari internet, pada kesempatan kali ini saya akan mencontohkan melakukan port forwarding pada mikrotik menggunakan winbox dengan persepsi settingan standart mikrotik sudah dilakukan dan IP Public terpasang pada mikrotik.




  1. Klik IP - Firewall - NAT
  2. Klik Add / Tambah dan masukkan settingan seperti berikut tab General, isikan Chain dengan dstnat, masukkan IP Public pada Dst. Address, Pilih protocol tcp dan isikan Port sewaktu mengakses dari internet :
    Port Forward Mikrotik NAT
  3. Setelah itu pindah ke tab Action, pilih dst-nat pada Action dan masukkan alamat IP Address local DVR CCTV ke To Addresses dan masukkan port DVR pada bagian To Ports.
    Port Forwarding Mikrotik Untuk CCTV
  4. Klik OK dan silahkan lakukan pengujian.

Sekian cara melakukan port forwarding pada mikrotik, yang pada contoh kali ini saya mencoba melakukan port forwarding mikrotik untuk CCTV agar dapat diakses dari luar jaringan / dari internet.

Monday, July 3, 2017

KONFIGURASI LOAD BALANCING MIKROTIK

Metode load balancing banyak orang yang salah mengartikan, kebanyakan dari mereka menganggap bahwa dengan melakukan load balancing maka kecepatan atau bandwith internet akan diakumulasi.
Misal :

  • ISP 1 bandwith 5 Mb
  • ISP 2 bandwith 3 Mb
Kebanyakan akan menganggap setelah di load balancing jaringan mereka memiliki bandwith 8 Mb, padahal yang terjadi tidak seperti itu, load balancing hanya akan membagi dan berusaha menyeimbangkan pemakaian bandwith menurut jumlah paket yang keluar, jadi akan tetap tidak imbang apabila jumlah paket yang masuk ISP 1 dan ISP 2 ukurannya berbeda.

Namun dengan metode ini setidaknya distribusi pemakaian bandwith antara ISP 1 dan ISP 2 dibagi secara rata sesuai jumlah paket dan efeknya adalah mengurangi kemungkinan 1 ISP sampai habis bandwithnya terpakai dan ISP lainnya free. Berikut contoh konfigurasi load balancing mikrotik.

ISP 1 : 192.168.1.1/24
ISP 2 : 192.168.2.1/24

  1. Ubah nama Interface menjadi ISP1, ISP2 dan LAN
  2. Tambahkan IP Address untuk Interface ISP 1, ISP 2 dan LAN


  3. Setting pada IP - Firewall - Mangle, untuk menandai Connection dan Routing kedua ISP
    > Mark Connection ISP 1:


    > Mark Connectin ISP 2 ( Dengan cara seperti mark connection ISP 1 )

    >  Mark Routing ISP 1 :


    > Mark Routing ISP 2 ( Dengan cara seperti mark routing ISP 1 )
  4. Lakukan setting NAT pada IP - Firewall - NAT untuk kedua ISP

    lakukan juga untuk ISP 2.
  5. Buat routingan untuk kedua ISP dan routingan utama pada IP - Routes - Klik + (untuk menambahkan routingan baru).
    > Buat Default Routing untuk ISP 1 :


    > Buat Default Routing untuk ISP 2 :


    > Buat Default Routing Utama :

Dan akhirnya sampai pada tahap pengujian settingan load balancing. Anda bisa melihat pada statistik masing-masing interface baik di ISP 1 dan ISP 2 mikrotik jika anda melakukan aktifitas browsing dll dari PC client. 

Thursday, June 29, 2017

Memberikan Nilai Cost Pada Routing OSPF

OSPF (Open Shortest Path First) adalah bagian dari routing protokol yang hanya dimiliki oleh cisco, tentu bukan tanpa alasan mengapa OSPF menjadi salah satu routing protokol yang dianggap handal. OSPF memiliki kemampuan untuk menilai cost terbaik dari sebuah rute pengiriman data, cost ini ditentukan oleh interface yang dilalui oleh data tersebut.

Misalkan apabila suatu data melalui perangkat yang memiliki 2 interface dimana interface pertama adalah fastehternet dan interface kedua adalah ethernet maka data akan dilewatkan ke interface yang dianggap lebih baik dalam hal ini fastethernet. Kemampuan memberikan penilaian atau cost ini yang menjadi salah satu pembeda OSPF dan juga merupakan keunggulannya. Tidak perlu khawatir admin dari suatu jaringan bisa secara manual memberikan nilai cost. Berikut contoh konfigurasi OSPF mengunakan cost :

Apabila kita menggunakan cara routing OSPF seperti biasa tentu saja bisa, namun agar sedikit berbeda kali ini kita akan mencoba membuat routingan menjadi searah jarum jam memanfaatkan cost pada OSPF, semakin kecil cost maka semakin menjadi prioritas.

Router0 :
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface gigabitEthernet 0/1
Router(config-if)#ip ospf cost 1
Router(config-if)#exit 
Router(config)#interface gigabitEthernet 0/2
Router(config-if)#ip ospf cost 100
Router(config-if)#exit

Router(config)#router ospf 1
Router(config-router)#network 192.168.1.0 0.0.0.255 area 1
Router(config-router)#network 192.168.5.0 0.0.0.255 area 1
Router(config-router)#network 192.168.8.0 0.0.0.255 area 1
Router(config-router)#exit
Router(config)#exit


Router1 :
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface gigabitEthernet 0/1
Router(config-if)#ip ospf cost 100
Router(config-if)#exit 
Router(config)#interface gigabitEthernet 0/2
Router(config-if)#ip ospf cost 1
Router(config-if)#exit

Router(config)#router ospf 1
Router(config-router)#network 192.168.2.0 0.0.0.255 area 1
Router(config-router)#network 192.168.7.0 0.0.0.255 area 1
Router(config-router)#network 192.168.8.0 0.0.0.255 area 1
Router(config-router)#exit
Router(config)#exit


Router2 :
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface gigabitEthernet 0/1
Router(config-if)#ip ospf cost 100
Router(config-if)#exit 
Router(config)#interface gigabitEthernet 0/2
Router(config-if)#ip ospf cost 1
Router(config-if)#exit

Router(config)#router ospf 1
Router(config-router)#network 192.168.3.0 0.0.0.255 area 1
Router(config-router)#network 192.168.5.0 0.0.0.255 area 1
Router(config-router)#network 192.168.6.0 0.0.0.255 area 1
Router(config-router)#exit
Router(config)#exit


Router3 :
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface gigabitEthernet 0/1
Router(config-if)#ip ospf cost 100
Router(config-if)#exit 
Router(config)#interface gigabitEthernet 0/2
Router(config-if)#ip ospf cost 1
Router(config-if)#exit

Router(config)#router ospf 1
Router(config-router)#network 192.168.4.0 0.0.0.255 area 1
Router(config-router)#network 192.168.6.0 0.0.0.255 area 1
Router(config-router)#network 192.168.7.0 0.0.0.255 area 1
Router(config-router)#exit
Router(config)#exit


Dengan konfigurasi seperti di atas pada semua router maka routing akan berjalan searah dengan jarum jam karena nilai cost searah jarum jam lebih kecil dan menjadi prioritas utama. Apabila masih ada yang kurang jelas silahkan meninggalkan komentar.

Wednesday, June 28, 2017

KONFIGURASI VPN MIKROTIK

Salah satu fitur yang sudah disediakan mikrotik adalah untuk membuat VPN (Virtual Private Network), namun mungkin tidak semua dari kita memahami akan fungsi dari VPN ini sendiri. Contoh simpel dari fungsi VPN yang sering digunakan oleh kantor adalah agar kita dapat mengakses network atau jaringan kantor ketika kita berada di luar kantor dengan menggunakan bantuan internet, sehingga kita dapat mengakses data - data yang ada di server kantor tanpa perlu harus datang, atau kalau untuk IT lebih sering digunakan untuk mengakses server yang tidak memiliki akses secara public.
Berikut kita akan mencoba membuat VPN pada mikrotik sehingga network atau jaringan bisa diakses dari luar atau dari internet. Step by step untuk melakukan konfigurasi VPN sebagai berikut :

  1. Agar user yang terkoneksi ke VPN mendapatkan alamat IP yang sesuai maka kita perlu membuat Pool pada mikrotik. Masuk menu IP - Pool - Klik + untuk menambahkan Pool dan isikan seperti berikut kemudian klik OK.

  2. Setelah Pool dibuat kemudian kita perlu melakukan setting pada PPP, buka menu PPP - Profiles - Klik + untuk menambahkan Profiles dan isika seperti berikut kemudian klik OK



  3. Selanjutnya masuk ke PPP - Secrets - Klik + untuk menambahkan, dan isikan username dan password yang akan digunakan ketika melakukan dial ke VPN dan masukkan Profiles yang tadi kita buat seperti berikut dan klik OK

Untuk melakukan uji coba mengakses VPN silahkan anda menggunakan network diluar jaringnan mikrotik yang anda setting tadi, kemudian coba create atau buat koneksi VPN dengan dial ke IP public dan masukkan username password sesuai settingan anda, apabila terkoneksi dan dapat mengakses data di network / jaringan mikrotik maka konfigurasi telah sukses.


Tuesday, June 27, 2017

KONFIGURASI DASAR MIKROTIK

Mikrotik merupakan salah satu routerboard yang cukup populer, hal ini dikarenakan cara konfigurasinya yang cukup mudah dan memiliki harga yang sangat terjangkau (harga tergantung tipe mikrotik), pada kesempatan kali ini saya akan membuat panduan untuk melakukan konfigurasi atau settingan dasar mikrotik yang bisa digunakan untuk kantor skala kecil ataupun warnet.

Skenario dari konfigurasi Mikrotik RB1100 AHX2 pada kesempatan ini adalah kita memiliki sebuah koneksi dari Indihome yang akan kita masukkan mikrotik untuk dimanage ke client. Dan topologinya seperti di bawah :


  • Modem Indihome
    IP Address : 192.168.50.1
    Netmask : 255.255.255.0
  • Mikrotik

    Ethernet 1 (Interface Internet)-->
    IP Address : 192.168.50.2
    Netmask : 255.255.255.0
    Gateway : 192.168.50.1

    Ethernet 2 (LAN) -->
    IP Address : 192.168.20.1
    Netmask : 255.255.255.0

    DHCP : 192.168.20.100 - 192.168.20.150
    DNS ; 118.98.44.100, 118.98.44.20, 202.134.1.10, 202.134.0.155

Berikut step untuk konfigurasi dasar mikrotik :
  1. Koneksikan PC / Laptop yang ada winbox v3 ke jaringan yang sama dengan Mikrotik
  2. Pilih submenu Neighboards dan pilih Mac Address dari Mikrotik tersebut dan double klik untuk mengakses
  3. Apabila sebelumnya sudah di setting masukkan IP, Username dan Password sesuai settingan anda kemudian pilih Connect
  4. Ubah nama mikrotik pada menu System - Identity  ganti sesuai dengan nama yang diinginkan kemudian klik OK 
  5. Ganti interface pada Ethernet 1 menjadi INTERNET dan Ethernet 2 menjadi LAN, Contoh untuk interface internet seperti berikut dan lakukan juga untuk interface LAN :
  6. Tambahkan IP Address untuk masing - masing interface, sesuai dengan skenario di atas yang berarti untuk Interface Internet memiliki IP Address 192.168.50.2 Netmask 255.255.255.0 dan Interface LAN memiliki IP Address 192.168.20.1 Netmask 255.255.255.0:
    klik menu IP  - Addresses , kemudian klik tombol + untuk menambahkan IP seperti berikut.

  7. Tambahkan default route dari menu, IP - Routes - Klik + untuk menambahkan routing , sesuaikan settingan seperti di bawah kemudian klik OK
  8. Kemudian tambahkan DNS pada menu IP - DNS dan isikan sesuai DNS kalian lalu OK
  9. Sampai disini seharusnya mikrotik sudah bisa melakukan ping ke google, namun agar client dapat akses ke internet maka harus dilakukan proses NAT, dengan cara masuk menu IP - Firewall - Nat , pada tab general dan tab action isikan seperti berikut kemudian OK.

  10. Langkah terakhir agar client mendapatkan IP Address secara otomatis maka kita perlu melakukan setting pada DHCP, pertama untuk dapat menentukan range IP yang akan digunakan untuk DHCP maka perlu di create Pool melalui menu IP - Pool - Klik + untuk menambahkan Pool kemudian klik OK:
  11. Setelah pool sudah dibuat maka masuk menu DHCP pada IP - DHCP Server - Klik + untuk menambahkan DCHP kemudian isikan seperti di bawah kemudian OK
Sampai disini harusnya semua settingan standart yang dibutuhkan sudah kita lakukan, step selanjutanya tinggal mencoba di client untuk browsing apabila berhasil maka semua settingan di atas sudah berhasil.


Monday, June 26, 2017

Menggabungkan Kombinasi Routing RIP v2, OSPF dan Static

Pada kesemptan kali ini saya akan coba berbagi pengalaman mengenai menggabungkan beberapa jenis routing sekaligus, rasanya memang tidak terlalu penting apabila kita tidak bekerja di suatu provider tapi untuk sekedar menambah pengetahuan tidak ada yang salah.

Langsung saja pada materi kali ini saya akan menggunakan RIP v2, OSPF dan juga routing Static dengan bentuk jaringan dan ip address seperti di bawah :

Untuk mempermudah konfigurasi maka kita pisahkan network sesuai dengan jenis routing yang akan digunakan, pembagiannya sesuai gambar akan menjadi seperti berikut :

  • Routing Dinamis RIP :
    Network 192.168.1.0 / 24
    Network 192.168.2.0 / 24
    Network 192.168.3.0 / 24
    Network 192.168.7.0 / 24
  • Routing Dinamis OSPF
    Network 192.168.4.0 / 24
    Network 192.168.5.0 / 24
    Network 192.168.6.0 / 24
    Network 192.168.8.0 / 24
  • Routing Static
    Network 192.168.9.0 / 24
    Network 192.168.10.0 / 24
Setelah dilakukan pembagian seperti di atas maka kita bisa langsung melakukan konfigurasi untuk setiap router sesuai dengan routingan yang sudah ditentukan.

ROUTER 0
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.7.0

ROUTER 1
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.2.0

Router(config-router)#network 192.168.3.0

Router 3
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network
Router(config-router)#network 192.168.4.0 0.0.0.255 area 0
Router(config-router)#network 192.168.8.0 0.0.0.255 area 0
Router(config-router)#network 192.168.6.0 0.0.0.255 area 0

Router 4
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network
Router(config-router)#network 192.168.5.0 0.0.0.255 area 0
Router(config-router)#network 192.168.6.0 0.0.0.255 area 0

ROUTER 5
Routing Static ke 0.0.0.0 Mask 0.0.0.0 Gateway 192.168.10.1

Router 2 (Agar routingan OSPF mengenali RIP v2)
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network
Router(config-router)#network 192.168.7.0 0.0.0.255 area 0
Router(config-router)#network 192.168.8.0 0.0.0.255 area 0
Router(config-router)#Redistribute RIP


Router 2 (Agar routingan RIP v2 mengenali OSPF)
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 192.168.7.0
Router(config-router)#network 192.168.8.0
Router(config-router)#version 2
Router(config-router)#Redistribute ospf 1 metric 1

Router 2 (Agar routing RIP v2 dan OSPF mengenali routingan Static)
Static routing 192.168.9.0 255.255.255.0 192.168.10.2

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#Redistribute static
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#Redistribute static

Sekian cara mengkombinasikan beberapa macam routing, apabila ada hal yang kurang jelas silahkan meninggalkan pada kolom komentar, terimakasih.

Saturday, June 24, 2017

Menjalankan Python Pada Startup Raspberry Pi

Bahas pemrograman python cukup banyak digunakan para developer, dengan munculnya dan semakin boomingnya perangkat raspberry maka bahasa python ini pun ikut semakin populer digunakan oleh para programmer untuk membuat aplikasi di raspberry. Tentunya akan sangat dibutuhkan agar program secara otomatis dijalankan setelah perangkat raspberry dinyalakan agar tidak dibutuhkan untuk start program secara manual.

Berikut cara untuk menjalankan python pada startup raspberry menggunakan crontab :
  1. Apabila script yang ditulis memiliki hubungan atau dependensi dengan file lain yang ada pada satu folder maka saya akan membuat bash script terlebih dahulu, berikut contohnya :
    nano new_startup_program.sh
  2. Di dalam file new_startup_program.sh isikan script seperti di bawah :
    #!bin/sh

    cd /
    cd /home/pi/
    python nama_program.py &
    cd /
  3. Kemudian save dan exit.
  4. Ubah permission dari new_startup_program.sh dengan cara :
    chmod 775 new_startup_program.sh
  5. Setelah semua selesai coba jalankan script berikut untuk menguji apakah bash file sudah berhasil :
    sh new_startup_program.sh
  6. Apabila sudah berhasil tambahkan ke crontab  :
    sudo crontab -e
  7. Untuk pertama kali kita akan diminta untuk memilih editor yang akan digunakan, saya lebih merekomendasikan editor NANO karena paling mudah menurut saya, pilih 2 untuk memilih editor tersebut. Setelah masuk ke dalam file ketikkan script berikut di baris paling akhir sebelum exit :
    @reboot sh /home/pi/new_startup_program.sh
  8. Save dan exit dengan Ctrl-x dan Y
  9. Restart raspberry untuk uji coba
Sekian step by step untuk membuat script python menjadi startup pada raspberry pi.

Friday, June 23, 2017

Monitoring Status Pengiriman atau Terima Email VPS

Bagi para admin server atau dalam hal ini lebih tepatnya mail server akan sangat membantu apabila kita dapat melakukan monitoring terhadap proses kirim atau terima email dari para client kita, karena apabila terjadi suatu hal dapat kita bantu untuk cek apakah status dari email tersebut.
Pada VPS caranya cukup mudah, login WHM dengan www.alamatwebsite.com/whm


Login dengan root, kemudian cari menu Mail Delivery Report seperti contoh di bawah ini


Agar kita dapat menemukan status email yang kita inginkan masukkan filter sesuai dengan kebutuhan, setelah itu klik tombol Run Report untuk memunculkan data.

Thursday, June 22, 2017

KONFIGURASI VLAN

VLAN (Virtual Lan) sebuah model jaringan yang tidak terbatas pada kondisi atau lokasi secara fisik, karena dengan menggunakan model ini jaringan akan dapat dikonfigurasi secara virtual tanpa harus menuruti lokasi fisik dari perangkat tersebut. Penggunaan VLAN akan membuat pengaturan jaringan menjadi lebih flexibel. Berikut contoh konfigurasi VLAN :



Switch>enable
Switch#vlan database
Switch(vlan)#vlan 10 name A
Switch(vlan)#vlan 20 name B
Switch(vlan)#exit
Switch#configure terminal
Switch(config)#interface fastethernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#interface fastethernet 0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#interface fastethernet 0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#interface fastethernet 0/5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#end
Switch#configure terminal
Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#end


Router>enable
Router#configure t
Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown
Router(config-if)#interface fastethernet 0/0.1
Router(config-subif)#encapsulation dot1Q 1
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config-subif)#interface fastethernet 0/0.2
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.1.1 255.255.255.0
Router(config-subif)#interface fastethernet 0/0.3
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.2.1 255.255.255.0

Router(config-subif)#end

Wednesday, June 21, 2017

Monitoring Traffic Interface Router Cisco

Sebagai admin jaringan tentu kita membutuhkan untuk memonitoring traffic yang terjadi pada jaringan kita, pada kesempatan kali ini saya akan sedikit berbagi mengenai cara melihat atau melakukan monitoring terhadap setiap interface dari Router Cisco kita, kalau kita menggunakan router mikrotik fitur ini disebut Torch. Berikut step dan juga capture untuk mempermudah dalam memahami panduan ini :

  1. Masuk ke mode root dari cisco anda.
  2. Untuk step awal, tentukan interface mana saja yang akan dimonitoring. Pada contoh kali ini saya akan melakukan monitoring terhadap interface VLAN1 dan FastEhternet0.
  3. Mulai masuk ke bagian interface yang sudah ditentukan kemudian ketikkan perintah :
    #ip flow ingress
    #ip flow egress
  4. Keluar dari interface, namun tetap masuk pada bagian configure-terminal dan ketikkan command berikut untuk membantu filter, pada contoh kali ini saya akan menampilkan 15 pengguna traffice tertinggi dan dilakukan sorting berdasarkan besar traffic pada setiap interface :
    #ip flow-top-talkers
    #top 15
    #sort-by bytes
  5. Setelah semua interface yang ingin di monitoring sudah ditambahkan command di atas, save konfigurasi dengan cara :
    #copy running-config to startup-config
  6. Pastikan konfigurasi tersimpan dengan cara restart router, dan pastikan perintah pada nomor 3 sudah masuk pada bagian startup-config, cara melakukan pengecekan dengan perintah :
    #show running-config
  7. Jika konfigurasi point nomor 3 berhasil dan tersimpan maka akan terlihat seperti berikut pada running-config :
  8. Dan jika konfigurasi nomor 4 berhasil maka pada running-config juga akan ditemui :
  9. Apabila semua konfigurasi sudah berhasil, selanjutnya setiap kita akan melakukan pengecekan terhadap salah satu interface router hanya perlu mengetikkan perintah seperti di bawah pada posisi configure-terminal:
    #show ip flow top-talkers

Sekian cara untuk melakukan monitoring traffic pada setiap interface dari router cisco, Tujuannya adalah agar kita dapat mengetahui traffic mana yang memberikan beban ke jaringan kita sehingga tau apa yang harus kita lakukan.

Tuesday, June 20, 2017

KONFIGURASI ROUTER DINAMIS CISCO OSPF

Setelah pada artikel sebelumnya saya membahas Konfigurasi Routing Dinamis Cisco RIP, maka pada kesempatan kali ini saya akan membahas mengenai konfigurasi routing dinamis OSPF. Meskipun terkesan sama routing dinamis namun ada perbedaan antara RIP dan OSPF yang akan saya bahas di artikel lainnya. Berikut bentuk jaringan yang akan kita coba untuk kita implementasikan routing OSPF :

Router0 :
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 192.168.1.0 0.0.0.255 area 1
Router(config-router)#network 192.168.5.0 0.0.0.255 area 1
Router(config-router)#network 192.168.8.0 0.0.0.255 area 1
Router(config-router)#exit
Router(config)#exit

Router#exit

Router1 :
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 192.168.2.0 0.0.0.255 area 1
Router(config-router)#network 192.168.7.0 0.0.0.255 area 1
Router(config-router)#network 192.168.8.0 0.0.0.255 area 1
Router(config-router)#exit
Router(config)#exit

Router#exit

Router2 :
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 192.168.3.0 0.0.0.255 area 1
Router(config-router)#network 192.168.5.0 0.0.0.255 area 1
Router(config-router)#network 192.168.6.0 0.0.0.255 area 1
Router(config-router)#exit
Router(config)#exit

Router#exit

Router3 :
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 1
Router(config-router)#network 192.168.4.0 0.0.0.255 area 1
Router(config-router)#network 192.168.6.0 0.0.0.255 area 1
Router(config-router)#network 192.168.7.0 0.0.0.255 area 1
Router(config-router)#exit
Router(config)#exit

Router#exit

Secara konsep mirip dengan routing dinamis RIP, yaitu mendaftarkan setiap network yang terhubung langsung dengan router. Yang menjadi perbedaan pada ospf ini setelah memasukkan network maka akan memasukkan nilai wildcard dan menentukan area (harus di dalam satu area).

Monday, June 19, 2017

Unblock IP dari VPS WHM

Sebagai pengguna VPS (Virtual Private Server) adakalanya ip dari provider kita di block secara otomatis oleh server VPS, dampak dari hal ini adalah kita tidak dapat mengakses server VPS dan bahkan email menjadi tidak bisa kirim ataupun terima apabila kita menggunakan jaringan provider tersebut.
Apabila terjadi hal seperti ini solusinya adalah dengan melakukan unblock IP Public provider kita apabila sudah yakin mmang tidak ada masalah pada network kita. Caraya cukup mudah, login akun WHM dengan cara ketikan : www.alamatblog.com/whm.


Login dengan akun root anda untuk dapat melakukan perubahan konfigurasi, setelah berhasil login cari menu ConfigServer Security & Firewall


Cari bagian Quick Unblock dan apabila sudah ketemu masukkan IP Public dari provider anda 


Apabila sudah di klik Quick Unblock maka seharusnya sudah selesai, silahkan coba untuk melakukan email atau test ping ke IP Public dari VPS anda.